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Preface 

OpenL Tablets is a Business Rules Management System (BRMS) based on tables presented in Excel 

and Word documents. Using unique concepts, OpenL Tablets facilitates treating business documents 

containing business logic specifications as executable source code.  

OpenL Tablets provides a set of tools addressing BRMS related capabilities including OpenL Tablets 

Web Studio that can be used by both business analysts and developers for creating, testing and 

managing their business rules and business rule projects, and OpenL Tablets Web Services designed 

for developers for integration of business rules with their applications. 

The OpenL Tablets Installation Guide provides instructions for installing and customizing OpenL 

Tablets software. The document describes how to install OpenL Tablets under Apache Tomcat and as 

Eclipse plugin. If you choose the last way of installation, you will be able to use a set of tutorials and 

examples designed to help you better understand OpenL Tablets features and functionality. Information 

on how to deploy and setup OpenL Web Services is provided as well. 

How This Book Is Organized 

Chapter 1 lists system requirements for installing and using OpenL Tablets software. 

Chapter 2 explains how to install OpenL Tablets Web Studio under Apache Tomcat. 

Chapter 3 describes the installation of OpenL Tablets Web Studio under Eclipse. 

Chapter 4 is designed for developers and describes how to deploy OpenL Tablets Web Services. 

Chapter 5 explains how to setup OpenL Tablets Web Studio and Web Services as an integrated 

environment. 

FAQs and Troubleshooting Notes sections provide useful information related to OpenL Tablets 

installation. 

Audience 

This guide is mainly targeted at business users and rule experts who will define, view, and manage 

their business rules and rule projects via OpenL Tablets Web Studio. Developers will also use this 

document to learn how to install and setup OpenL Web Services. 

Basic knowledge of Java, Eclipse, and Apache Tomcat is required to use this guide effectively. 

Related Information 
The following table lists sources of information related to contents of this guide: 
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Related information 

Title Description 

OpenL Tablets WebStudio User Guide Document describing OpenL Web Studio, a web application for 
managing OpenL Tablets projects through web browser. 

OpenL Tablets Reference Guide  Provides overview of OpenL Tablets technology, as well as its basic 
concepts and principles. 

http://openl-tablets.sourceforge.net/ OpenL Tablets open source project website. 

Typographic Conventions 
The following styles and conventions are used in this guide:  

Typographic styles and conventions 

Convention Description 

Bold  Represents user interface items such as check boxes, command buttons, dialog 
boxes, drop-down list values, field names, menu commands, menus, option 
buttons, perspectives, tabs, tooltip labels, tree elements, views, and windows. 

 Represents keys, such as F9 or CTRL+A. 

 Represents a term the first time it is defined. 

Courier Represents file and directory names, code, system messages, and command-line 
commands.  

Courier Bold Represents emphasized text in code.  

Select File > Save 
As 

Represents a command to perform, such as opening the File menu and selecting Save 
As.  

Italic  Represents any information to be entered in a field.  

 Represents documentation titles.  

<  > Represents placeholder values to be substituted with user specific values.  

Hyperlink Represents a hyperlink. Clicking a hyperlink displays the information topic or 
external source. 

http://openl-tablets.sourceforge.net/docs/guide/html/5.8.0/OpenLWebStudio_UserGuide/index.html
http://openl-tablets.sourceforge.net/
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Chapter 1: Before You Begin  
This chapter covers system requirements for installing and running OpenL Tablets software provided in 
the following table. 
 
Software requirements 

Operating systems Microsoft Windows XP (SP2 or higher), Vista, Windows 7 x32/64; Ubuntu 9.x; Linux 3.x
1
 

Browsers Microsoft Internet Explorer 9 or later, Firefox 9.0 or later, Chrome 16 or later 

Other Software
2
  Java v 6 - JDK 1.6.0_x  or later 

 Apache Tomcat 7.0.x or later 

 Eclipse 3.6 or later 

Hardware requirements 

  RAM 1 Gb min (2 Gb is recommended) 

 CPU Intel(R) Core (TM) or equivalent 

User rights requirements 

  You must have administrative permissions in order to install the software on 
Microsoft Windows / UNIX. 

 
NOTE: We highly recommend you to avoid using spaces and special characters in paths. 
 

                                                
1
 OpenL Tablets software can potentially run on any Operating System that supports Java Virtual Machine, for 

example Mac OS. In the table we provided operating systems on which the OpenL Tablets software is tested and 
supported. 
2
 Instructions on how to install and configure these software packages are provided further in this document. 
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Chapter 2: Install OpenL Tablets Web Studio 
under Apache Tomcat 

This chapter describes how to setup an environment for working with OpenL Tablets software, how to 
deploy OpenL Tablets Web Studio under Apache Tomcat, and also provides information about settings 
required for proper functioning of the application. 

Follow these steps: 

Step 1: Install Java Development Kit (JDK). 

Step 2: Install Apache Tomcat 

Step 3: Deploy OpenL Tablets Web Studio 

 

Step 1: Installing the JDK  

Follow the steps below to install the JDK. 
 

1. Download JDK 1.6.0_x or later from 

http://www.oracle.com/technetwork/java/javase/downloads/index.html to the target directory. 

Further in the document this catalog is referred as <JAVA_DIR>. 

NOTE: We highly recommend you to avoid installing Java in the default Program Files 

directory because it may cause some problems due to space characters in the path to the 

folder.   

2. Refer to http://www.oracle.com/technetwork/java/javase/index-137561.html for installation 

details if required. 

3. Install the JDK according to the instructions.  

4. Set the environment variable JAVA_HOME to the pathname of the directory where the JDK is 

installed as follows: 

a. For Microsoft Windows: 

i. Open the System Properties dialog: press <Windows> + <Pause> hotkey or 

right-click the My Computer icon and select Properties in the pop-up menu. 

ii. On the Advanced tab, click the Environment Variables button. 

iii. In the System variables area, click the New button 

iv. Enter JAVA_HOME in the Variable name field. 

v. Enter the path to the directory where the JDK is installed in the Variable value 

field, for example, C:\Java\jdk1.6.0_20. 

vi.  Click OK to complete. 

b. For Unix/Linux environments (let’s assume that the target directory is 

/usr/lib/jvm/java-6-sun): 

To set up JAVA_HOME for a single user: 

http://www.oracle.com/technetwork/java/javase/downloads/index.html
http://www.oracle.com/technetwork/java/javase/index-137561.html
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i. Login to your account and open .bash_profile: 

      nano ~/.bash_profile 

ii. Add the following line: 

      export JAVA_HOME=/usr/lib/jvm/java-6-sun 

iii. Add/correct system PATH 

     export PATH=$PATH:$JAVA_HOME/bin 

iv. Press CTRL+O to save your work, and then press CTRL+X to exit. 

To set up JAVA_HOME for all users: 

i. Login as root and open /etc/profile: 

  nano /etc/profile 

ii.  Add the following line 

      export JAVA_HOME=/usr/lib/jvm/java-6-sun 

iii. Add/correct system PATH 

export PATH=$PATH:$JAVA_HOME/bin 

Step 2: Installing Apache Tomcat 

Follow the steps below to install Apache Tomcat 7.0.x (or later): 

1. Download Tomcat from http://tomcat.apache.org/index.html.  

2. Save zip file in a temporary directory. 

3. Unpack downloaded zip into target folder on your computer.  

This folder is referred as <TOMCAT_HOME> further in this document. 

4. Configure JVM options for Tomcat web server as follows: 

a. For Windows, create TOMCAT_HOME/bin/setenv.bat file and write:  

set JAVA_OPTS=%JAVA_OPTS% -Xms256m -Xmx1024m -XX:+UseParallelOldGC -

XX:PermSize=128m -XX:MaxPermSize=256m 

For UNIX, create TOMCAT_HOME/bin/setenv.sh file and write  

export JAVA_OPTS="$JAVA_OPTS -Xms256m -Xmx1024m -XX:+UseParallelOldGC -

XX:PermSize=128m -XX:MaxPermSize=256m" 

Step 3: Deploying OpenL Tablets Web Studio 

This section describes how to deploy and run OpenL Tablets Web Studio under Tomcat on a Windows 
machine.   

1. Go to http://openl-tablets.sourceforge.net/downloads page. 

2. Click the appropriate WebStudio link. 

3. Save the file in the temporary folder. 

4. Copy the Web Studio war file (for example, openl-tablets-webstudio-X.X.X.war) to 

the TOMCAT_HOME\webapps folder. 

5. Run Tomcat by clicking the startup.bat file in TOMCAT_HOME\bin. 

http://tomcat.apache.org/index.html
http://openl-tablets.sourceforge.net/downloads
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As Tomcat starts it unpacks the war file into the TOMCAT_HOME\webapps\<war file 

name> folder. For example, for 5.8.1 version the target folder can be 

TOMCAT_HOME\webapps\openl-tablets-webstudio-5.8.1. For convenience, you 

can rename the folder as you need but please remember that you will use this name to 

launch Web Studio under Tomcat.  

6. Run OpenL Web Studio by entering in your browsed the following URL 

http://localhost:8080/<war file name>. I.e. for our example you should enter 

http://localhost:8080/openl-tablets-webstudio-5.8.1. 

 

As a result, OpenLTablets Web Studio opens in your browser. From this point, you can create 

new projects in the Web Studio or download existing ones.  
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Chapter 3: Install OpenL Tablets under Eclipse 

This chapter provides information on how to install OpenL Tablets under Eclipse. You will also learn 

how to run OpenL Tablets Web Studio under Eclipse. 

The installation process consists of the following steps: 

Step 1: Install Eclipse SDK. 

Step 2: Install and setup OpenL Tablets Wes Studio as Eclipse Plugin. 

Step 3: Run OpenL Tablets Web Studio. 

NOTE: If you have JDK and Eclipse SDK installed and properly set up on your computer, please skip 

Step 1 and Step 2. 

Prerequisites 

Make sure the following tasks have been performed: 

 The JDK 1.6.0_x (or later) is correctly installed. 

 An environment variable JAVA_HOME is set to the pathname of the directory where the JDK 

is installed. For more information on how to set up JAVA_HOME see Installing the JDK earlier 

in this document. 

Step 1: Installing Eclipse SDK  

1. Download Eclipse from http://www.eclipse.org/downloads/ to the target directory. 

NOTE: We recommend you to install the Eclipse Classic package.   

 

 

 

 

 

 

 

 

 

 

Tips for a newbie: Download Eclipse under Windows 

a. In the Eclipse Downloads page, locate the Eclipse Classic 3.x.x item 
b. Click Windows 32 or Windows 64 depending on your OS edition: 

 

   
  
c. Click the big green arrow to start downloading: 

 

  
 

d. Select Save File in the standard dialog window, choose the folder where to save Eclipse zip 
file, and click OK. 

e. Unzip the Eclipse zip file: right click the file name and select Unpack or Unpack here. 
 

Now you are ready to run Eclipse on your computer. 

http://www.eclipse.org/downloads/
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2. Navigate to the Eclipse folder and click eclipse.exe to run Eclipse. The Workspace 

Launcher dialog appears. 

3. In the Workspace Launcher dialog, specify your Eclipse workspace - the folder where your will 

save all OpenL Tablets projects. We recommend you to define the workspace as follows: 

\<OPENL_HOME>\local-workspace, where OPENL_HOME is the openl folder in the root 

directory of the non-system disk.  

NOTE: Please don’t use the C:\Documents and Settings\ folder that can be shown in 

the dialog by default. We highly recommend that you don’t select the system drive; and the path 

should not contain spaces. For example, your workspace folder can be \openl\local-

workspace. 

As a result, the Welcome to Eclipse window appears. From this point you can install OpenL Tablets 
under Eclipse as described in Step 2. 

Step 2: Installing OpenL Tablets under Eclipse 

You can install OpenL Tablets Eclipse Plugin in one of the following ways: 

 Remotely from the Sourceforge.net site 

 From Zip file 

IMPORTANT! If you have OpenL Tablets already installed in Eclipse, you should first remove 
previously configured settings, uninstall OpenL Tablets, and perform the installation as described 
below. 

You can remove the existing settings in one of the following ways.  

1. Delete the \<OPENL_HOME>\ folder. In this case, all rule projects saved in your workspace will 

be removed as well.  

2. If you want to save your rule projects, proceed as follows: 

a. Locate your workspace folder, for example, \<OPENL_HOME>\local-workspace. 

b. Delete the folders: .metadata, logs, org.openl.rules.webstudio. 

c. Open the \<OPENL_HOME>\system-settings folder and delete the 

system.properties file. 

To uninstall Eclipse SDK: 

1. Run Eclipse SDK.  
2. Select Help > About Eclipse SDK > Installation Details. 
3. Locate OpenL Tablets for Eclipse.  
4. Select it and click the Uninstall button. 
5. Click Finish to complete and select Restart Now to restart Eclipse. 

If you have any problems with uninstalling OpenL Tablets, please delete the existing Eclipse directory, 
unzip Eclipse zip file, and install a clear Eclipse as described in Step 2.  
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Remote Installation of OpenL Tablets Eclipse Plugin 

Follow the steps below to install the OpenL Tablets Eclipse Plugin remotely: 

1. Run Eclipse SDK. 

2. In the top line menu, select Help > Install New Software. The Install dialog appears. 

3. In the Work with text box, enter the URL: http://openl-tablets.sourceforge.net/eclipse-site/ and 

press Enter.  

4. Click the Select All button to select all items: 

 

 

Figure 1: Remote installation of OpenL Tablets under Eclipse 

 

5. In the Details area, clear the Contact all update sites during install to find required 

software checkbox. . 

6. Press the Next button and follow the installation steps: 
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a. Click the Next button in the Install Details window 

b. Select I accept option in the Review Licenses dialog to accept license agreements. 

c. Click Finish to complete. If the Security Warning dialog appears, click OK to proceed. 

7. After the installation is complete, you will be prompted to restart Eclipse SDK. Click the Restart 

Now button.  

Installation of OpenL Tablets Eclipse Plugin from Zip File 

1. Download the Eclipse Update Site zip file as follows: 

a. Open the OpenL Sourceforge Project page 

b. Click the openl-tablets link: 

 

c. In the Name column, navigate to the latest OpenL Tablets version and click its name. 

For example, for 5.8.1 version you will click the OpenL Tablets 5.8.1 link.  

d. Locate the openl-tablets-eclipse-site-<version>.zip file. For the version 

5.8.1 you should click the following link: 

 

e. Click the zip file name and save it in a target folder.  

2. Run Eclipse SDK. 

3. In the top line menu, select Help > Install New Software. 

4. Press the Add button.  

5. Type OpenL Tablets in the Name field.  

6. Press the Archive button. The Repository archive dialog appears. 

7. Locate the downloaded zip file and click the Open button. 

8. Click OK to proceed.  

9. Click the Select All button to select all items. 

10. In the Details area, clear the Contact all update sites during install to find required 
software checkbox.  

11. Press the Next button. 

12. Follow the installation dialog windows to download and install OpenL Tablets for Eclipse.  

13. Click OK in the Security Warning dialog. 

14. To Restart Eclipse, click the Restart Now button in the prompted dialog. 

RESULT: The Java – Eclipse SDK window appears. From this point, you can launch OpenL Tablets 
Web Studio as described in the following step. 

 

https://sourceforge.net/projects/openl-tablets/files/
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Step 3: Run OpenL Tablets Web Studio 

You should first add OpenL Tablets Web Studio to Eclipse as a new project and then launch it. 

1. Add OpenL Tablets to Eclipse as a new project  

a. From the top line menu, select File > New > Project.  

 
 

Figure 2: Add a new project in Eclipse 
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The New Project window appears. 

 

Figure 3: Select OpenL Tablets Web Studio as a new project 

b. In the tree, expand OpenL Tablets > OpenL Tools and select the OpenL WebStudio – 

Web based editing environment item. 

c. Click Next to proceed. 

d. In the following window, define where your projects will be located: select the Use 

default location or specify the desired one.  
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Figure 4: Define workspace for OpenL Tablets projects 

NOTE: Please remember to use paths without spaces or special characters. 

e. Click Finish to complete. 

RESULT: The org.openl.rules.webstudio item appears in the Package Explorer as illustrated in the 
Figure below. 
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Figure 5: OpenL Tablets package is added to Eclipse 

2. Run OpenL Tablets Web Studio: 

a. Expand the org.openl.rules.webstudio node. 
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Figure 6: Run OpenL Tablets Web Studio in Eclipse 

b. Right-click the StartTomcat WebStudio.launch item and select Run as > StartTomcat 

WebStudio in the pop-up menu.  

RESULT: OpenL Tablets Web Studio opens in the default browser.  
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Figure 7: OpenL Tablets Web Studio is open and ready for use 

NOTE:  OpenL Tablets Eclipse plugin provides several tutorials and example projects. To work with 
any of these projects, first you need to create them as new projects in the Eclipse SDK. The procedure 
is similar to described in Step 4: Run OpenL Tablets Web Studio. After that the projects are available in 
OpenL Tablets Web Studio and appear in the Select Module list. 
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Chapter 4: Deploy OpenL Tablets Web 
Services  

This chapter is designed for rule developers who will want to use business rules as separate web 

services.   

NOTE: We will consider a particular case when you will use a file system as a data source for your 

projects. In such a case all OpenL Tablets projects should be placed into a local folder; this folder will 

represent a single deployment containing all the projects. In turn, every project should also be 

represented as a separate folder. 

For more information on how to configure OpenL Tablets Web Services see the OpenL Tablets Web 

Services Usage and Customization guide. 

Prerequisites 

Make sure the following tasks have been performed: 

 The JDK 1.6.0_x (or later) and Apache Tomcat 7.0.x (or later) is correctly installed.  

We will refer the folder where Tomcat is installed as <TOMCAT_HOME>. 

  An environment variable JAVA_HOME is set to the pathname of the directory where the JDK 

is installed. 

 JVM options should be set up as described in the Installing Apache Tomcat section. 

The deployment process consists of the following steps: 

1. Download pre-configured OpenL Tablets Web Services application (war-file): 

a. Go to http://openl-tablets.sourceforge.net/downloads page. 

b. Click the appropriate Services Frontend (war) link. 

c.  Save the chosen war file to the <TOMCAT_HOME>\webapps directory. For 

example, let’s assume we saved the openl-tablets-ws-5.8.1.war file. 

2. Configure a local file system as a data source as follows: 

a. Navigate to the TOMCAT_HOME\webapps folder and unzip the web services war 

file. For example, you can right-click the web services war file name and select 7-
zip > Open archive. 

b. Open the WEB-INF\classes folders and locate the openl-ruleservice-

loader-beans.xml file. 

c. Right click the openl-ruleservice-loader-beans.xml file and select Edit 

in the popup menu. 

http://openl-tablets.sourceforge.net/downloads
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d. Override the following beans as shown below: 

<bean id="datasource" 

class="org.openl.rules.ruleservice.loader.FileSystemDataSource"> 

 <constructor-arg name="loadDeploymentsFromDirectory" value=".. path to the 

folder containing the projects…"/> 

</bean> 

3. Put your rule project to the /openl/datasource folder on the drive where you start 

Tomcat. Every rule project should be represented as a separate folder. As an example 
you can use OpenL Tablets Tutorial that you can download from the OpenL Tablets web 
site. 

4. Run Tomcat by clicking the startup.bat file in TOMCAT_HOME\bin. 

To ensure the deployment is successful you can try the web service with a tool at your option. 

NOTE: In the Tomcat log file you can find the URL that you should use to run your Web Service. For 

file system data source, the URL should look like http://localhost:8080/<ws war file name>/<datasource 

folder>/<rule project name>?wsdl, where <datasource folder>/<rule project name> can be taken from 

the Tomcat log file. 

http://openl-tablets.sourceforge.net/downloads
http://openl-tablets.sourceforge.net/downloads
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Chapter 5: OpenL Tablets Web Studio and 
Web Services Integration 

Earlier in this document we discussed how to install OpenL Tablets Web Studio, and also how to 
properly deploy and configure OpenL Tablets Web Services. 

This section describes how to setup an integrated environment that enables you to work with business 
rules from OpenL Tablets Web Studio and launch these rules as Web Services. Here we describe how 
to setup OpenL Tablets Web Studio and Web Services integration via RMI. 

NOTE: In the given example OpenL Tablets Web Studio should run under Tomcat. As a repository will 
be used common repository which you can download from OpenLTablets site, or request from OpenL 
Tablets team. 

1. If not done earlier, put and unzip jackrabbit and web services war files to the 

\TOMCAT_HOME\webapps. We recommend you to use the jackrabbit-webapp-

2.2.8.war file (you can download it from 

http://repo1.maven.org/maven2/org/apache/jackrabbit/jackrabbit-webapp/2.2.8/jackrabbit-
webapp-2.2.8.war).  

NOTE: You should also add the jcr-2.0.jar file to the \TOMCAT_HOME\webapps\ 

jackrabbit-webapp-2.2.8\WEB-INF\lib. You can download this file from 

http://search.maven.org/remotecontent?filepath=javax/jcr/jcr/2.0/jcr-2.0.jar 

2. From OpenL Tablets site, download the common repository zip file containing your rule to any 

folder. This location will be later used as datasource. In our example we use \openl\ folder. 

3. Set up jackrabbit.zip: 

a. Download the jackrabbit.zip file from the OpenL Tablets web site (Currently the file 

is not accessible from this site. Please refer to OpenL Tablets team for the file). Unpack 

the file to the \<TOMCAT_HOME>\bin\jackrabbit folder (create the jackrabbit 

folder if it does not exist). 

b. Locate \TOMCAT_HOME\webapps\bin \jackrabbit\bootstrap.properties file. 

It should contain the following lines: 

repository.config=jackrabbit/jackrabbit-repository.xml 

repository.home=D:/openl/common-repository 

repository.name=2TR 

# RMI Settings 

rmi.enabled=true 

rmi.port=0 

http://repo1.maven.org/maven2/org/apache/jackrabbit/jackrabbit-webapp/2.2.8/jackrabbit-webapp-2.2.8.war
http://repo1.maven.org/maven2/org/apache/jackrabbit/jackrabbit-webapp/2.2.8/jackrabbit-webapp-2.2.8.war
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rmi.host=localhost 

# If the URI is not specified, it's composed as follows: 

#rmi.uri=//${rmi.host}:${rmi.port}/${repository.name} 

rmi.url=//localhost:1099/2TR 

4. Set up Web Services as follows: 

a. Locate the \<TOMCAT_HOME>\webapps\<ws project name>\WEB-INF\classes\ 

rules-production.properties file. 

b. Update the rules-production.properties file. 

 Mark as comment these lines: 

# production-repository.factory = 

org.openl.rules.repository.factories.LocalJackrabbitProductionRepositor

yFactory 

# production-repository.local.home=/openl/common-repository 

 Remove the comment mark from these lines: 

production-repository.factory = 

org.openl.rules.repository.factories.RmiJackrabbitProductionRepositoryF

actory 

production-repository.remote.rmi.url = //localhost:1099/2TR 

5. Set up OpenL Tablets Web Studio: 

a. Download and unzip WebStudio war file to <TOMCAT_HOME>\webapps 

b. Locate \<OPENL_HOME>\system-settings – if the folder does not exist, create it and 

copy the system.properties file from \<TOMCAT_HOME>\webapps\<webstudio 

folder>\WEB-INF\conf to this folder. 

c. For Design repository 

 remove comment from design-repository.factory = 
org.openl.rules.repository.factories.RmiJackrabbitDesignRep

ositoryFactory   

 mark as comment #design-repository.factory = 
org.openl.rules.repository.factories.LocalJackrabbitDesignR

epositoryFactory) 

d. The same for Production repository: 
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 Remove comment from production-repository.factory = 
org.openl.rules.repository.factories.RmiJackrabbitProductionRepos

itoryFactory 

  

 Mark as comment  #production-repository.factory = 
org.openl.rules.repository.factories.LocalJackrabbitProductionRep

ositoryFactory 

NOTE: For the both repositories repository.remote.rmi.url = 
//localhost:1099/2TR 

e. Run Web Studio by entering in your browser http://localhost:8080/<WEbStudio war file 
name>. 

As a result, OpenL Tablets Web Studio home page appears with your project deployed. From this point 
you can make any changes in your rule in Web Studio, these change will immediately affect your rule 
represented as Web Service. 

NOTE: In the Tomcat log file you can find the URL that you should use to run your Web Service. The 
URL should look like http://localhost:8080/<ws war file name>/<deployment name>/<rule project 
name>?wsdl. 
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Troubleshooting Notes 

If you deploy OpenL Tablets Web Studio under Tomcat in Unix/Linux environment, the following 

troubleshooting recommendations can be taken into account. 

1. Before starting tomcat under Linux make sure that no java processes are running: 

sudo ps -A | grep j – if found, the process name and number will be displayed 

2. If any Java process is running, stop it: 

kill -9 <process number> 

3. Make sure that port 8080 is available: 

sudo netstart –an | grep8080 

4. Run Tomcat under Linux: 

startup.sh 

5. If the 'command not found' error appears, you should run .sh file as  executable script: 
/startup.sh 

6. If  one of the errors 'Permission denied' or 'The BASEDIR environment variable is not 
defined correctly' is shown then make all .sh files in the bin folder executable: 

chmod 777 *.sh 

7. Verify that all .sh files in the bin folder are executable: 

ls –l 

8. Run Tomcat 

/startup.sh 
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FAQs 
This section provides the most common questions and answer related to OpenL Tablets installation 
procedure. For detailed Information about working with Java, Eclipse, Tomcat, etc please refer to 
corresponding sites of the software manufacturers.  

1. Q: How can I check if Java is installed on my PC? 

1. R: You can do it as follows: 

For Windows XP: 

a. Open start > Control Panel 

b. Double click Add or Remove Programs 

For Windows 7/Vista: 

a. Open start > Control Panel 

b. Click Programs > Programs and Features 

Look through the list for ‘Java(TM)…’ or ‘Java(TM) Update…’ items. If any of them are present then 
you have Java installed on your PC. 

2. Q: During Java installation the page for Java registration appears. Do I have to register Java?  

2. R: No, it is optional. You can just close the registration page.  

3. Q: How can I check which version of Java is installed on my PC? 

3. R: Open the Verify Java Version page and click the Verify Java Version button. In just a few 
seconds a new page appears where you will find the message similar to the following one: 
“Your Java version: Version 6 Update 26”.  

4. Q: How can I see the error message in the Tomcat console that appears when I start Tomcat? 
The error screen disappears too quickly. 

4. R: Run catalina.bat run in the command line window as follows: click Start > Run, browse to 

<TOMCAT_HOME>\bin folder, select catalina.bat and add run in the command line. 

5. Q: When I try to start OpenL Tablets Web Studio under Eclipse in the Linux OS, ‘404 error’ 
occurs. 

5. R: Create the ‘openl’ folder in the root of the disk where Eclipse is installed with ‘write’ 
permission: 

chmod 777 openl 

To be sure the Web Studio will work properly, set the same permissions for the ‘Workspace’ 

folder. 

http://java.com/en/download/installed.jsp
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6. Q: When I try to run OpenL Tablets Web Studio in Eclipse, the following error message 
appears: 

Error occurred during initialization of VM 
Could not reserve enough space for object heap 

6. R: Restart your computer and try again. 


